Issues with Downloading Designs
Incident Report for Canva
Resolved
The issue is now resolved.
Posted Apr 18, 2018 - 08:14 AEST
Investigating
We're aware of an issue that some of the customers are unable to download their designs.
Posted Apr 18, 2018 - 07:56 AEST