Uploading and Downloading Issues
Incident Report for Canva
Resolved
The team has identified the problem and found a fix! Downloading designs and uploading should be working fine now. Thank you for your patience!
Posted 17 days ago. Feb 08, 2018 - 06:25 AEDT
Investigating
We’re currently experiencing issues with uploading and downloading. Our engineers are working on fixing this in the soonest possible time.
Posted 17 days ago. Feb 08, 2018 - 05:41 AEDT