Canva is currently inaccessible
Incident Report for Canva
Resolved
Thank you for your patience. Canva is now accessible.
Posted 16 days ago. Oct 07, 2017 - 15:14 AEDT
Investigating
We've received reports that Canva is currently inaccessible. Our engineers are investigating this and working on a solution.
Posted 16 days ago. Oct 07, 2017 - 14:45 AEDT