Intermittent upload Issues
Incident Report for Canva
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 09, 2018 - 22:03 AEDT
Investigating
We're currently experiencing intermittent issues with uploading images. Our engineers are working on fixing this at the soonest possible time.
Posted 9 months ago. Jan 09, 2018 - 21:51 AEDT