Download Issue
Incident Report for Canva
Resolved
This incident has been resolved.
Posted 14 days ago. Apr 10, 2018 - 01:05 AEST
Investigating
We're currently experiencing issues with Downloading. Our engineers are working on fixing this at the soonest possible time.
Posted 14 days ago. Apr 10, 2018 - 00:45 AEST