Canva is inaccessible: Error 500
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Apr 23, 2018 - 03:45 AEST
Investigating
We're currently experiencing issues with accessing Canva. Our engineers are working on fixing this at the soonest possible time.
Posted Apr 23, 2018 - 01:32 AEST