Canva is up and running
Incident Report for Canva
Resolved
This incident has been resolved.
Posted 18 days ago. Jun 08, 2017 - 00:05 AEST
Investigating
Canva is currently unavailable. We’re doing our best to resolve this ASAP and will provide updates.
Posted 18 days ago. Jun 07, 2017 - 23:38 AEST