Upload Issues
Incident Report for Canva
Resolved
The issue is now resolved.
Posted 8 months ago. Apr 09, 2018 - 17:29 AEST
Investigating
We’re currently aware of an issue affecting uploads, where users can't use uploaded images in the editor. We’re doing our best to resolve this ASAP and will provide updates once fixed.
Posted 8 months ago. Apr 09, 2018 - 17:11 AEST