Login Issue : Error 500 (Something Went Wrong)
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Jun 07, 2018 - 21:59 AEST
Investigating
We're getting reports from users in India encountering Error 500 (Something Went Wrong) when logging in. We're doing our best to resolve this ASAP and will provide timely updates.
Posted Jun 07, 2018 - 19:54 AEST
This incident affected: Mobile Applications (iPad app) and Editing designs, Viewing designs, Downloading designs, Media uploads.