Unable to upload images
Incident Report for Canva
Resolved
The issue with uploading images to Canva has been fixed. It's best to save your design then refresh your page, then try uploading again.
Posted 2 months ago. Aug 10, 2017 - 00:31 AEST
Investigating
We've received reports where users are unable to upload images to Canva and are getting an error. The team is already on it and working to fix it.
Posted 2 months ago. Aug 10, 2017 - 00:13 AEST