System Outage
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Sep 14, 2017 - 22:23 AEST
Investigating
We're doing our best to get this resolved immediately. Apologies for the inconvenience
Posted Sep 14, 2017 - 22:16 AEST