Partial outage
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Jun 08, 2018 - 06:16 AEST
Investigating
We are currently investigating this issue.
Posted Jun 08, 2018 - 04:31 AEST