Elevated Errors
Incident Report for Canva
Resolved
This incident has been resolved.
Posted about 1 year ago. Feb 02, 2018 - 12:23 AEDT
Investigating
We're experiencing an elevated level of errors and are currently looking into the issue.
Posted about 1 year ago. Feb 02, 2018 - 12:17 AEDT