Canva is inaccessible: Error 500
Incident Report for Canva
Resolved
Thank you for your patience. The error 500 issue has been fixed.
Posted 9 months ago. Jan 10, 2018 - 04:20 AEDT
Investigating
We're experiencing errors and are currently looking into the issue.
Posted 9 months ago. Jan 10, 2018 - 03:35 AEDT