Elevated Errors
Incident Report for Canva
Resolved
This incident has been resolved.
Posted 10 months ago. Feb 01, 2018 - 21:30 AEDT
Investigating
We're experiencing an elevated level of errors and are currently looking into the issue.
Posted 10 months ago. Feb 01, 2018 - 21:06 AEDT