Error 404 when accessing Canva
Incident Report for Canva
Resolved
The team has identified the problem and found a fix. You should be able to access Canva now. Thank you for your patience!
Posted Feb 21, 2018 - 16:19 AEDT
Investigating
We’re currently aware of an error (404) when accessing Canva. We’re doing our best to resolve this ASAP and will provide updates.
Posted Feb 21, 2018 - 15:51 AEDT