Error accessing some Canva designs
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Jul 11, 2018 - 05:51 AEST
Investigating
We’re currently experiencing issues with accessing some Canva designs. Our engineers are working on fixing this in the soonest possible time.
Posted Jul 11, 2018 - 05:28 AEST