Canva is unavailable
Incident Report for Canva
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 11, 2018 - 07:02 AEST
Investigating
We're currently experiencing issues with accessing Canva. Our engineers are working on fixing this at the soonest possible time.
Posted 5 months ago. Apr 11, 2018 - 06:37 AEST