Something went wrong (500)
Incident Report for Canva
Resolved
Thank you for your patience. The error 500 issue has been fixed.
Posted 10 months ago. Feb 02, 2018 - 05:27 AEDT
Investigating
We've received reports that users are unable to access Canva(error 500). Our engineers are investigating this and working on a solution.
Posted 10 months ago. Feb 02, 2018 - 05:03 AEDT